[Tobago] problems building

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Tobago] problems building

G. Ann Campbell
Hi,

We're having trouble building Tobago for SonarQube analysis on
http://nemo.sonarqube.org/.

Both in the CI job and locally, there's always this error:
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-dependency-plugin:2.8:unpack
(unpack-sources) on project tobago-sandbox: Unable to find artifact. Could
not find artifact
org.apache.myfaces.tobago:tobago-core:jar:sources:2.0.9-SNAPSHOT in
sonarsource-downloads (
http://nexus.internal.sonarsource.com/nexus/content/groups/ss-repo/)

My searches on this have come up empty. Can you point me in the right
direction?


Thx,
Ann

---
*G. Ann CAMPBELL* | SonarSource
Product Owner
http://sonarsource.com
Reply | Threaded
Open this post in threaded view
|

Re: [Tobago] problems building

Dennis Kieselhorst
Hi Ann,

sorry for the late response.

Which goals have you used and which Maven version are you using?
tobago-sandbox is part of the build (a module of tobago-extension), so
there should be no download necessary.

Does the problem also occur with the branch for Tobago 3.0.x
(https://svn.apache.org/repos/asf/myfaces/tobago/branches/tobago-3.0.x)?

Regards
Dennis

Am 08.10.2015 um 19:05 schrieb G. Ann Campbell:

> Hi,
>
> We're having trouble building Tobago for SonarQube analysis on
> http://nemo.sonarqube.org/.
>
> Both in the CI job and locally, there's always this error:
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-dependency-plugin:2.8:unpack
> (unpack-sources) on project tobago-sandbox: Unable to find artifact. Could
> not find artifact
> org.apache.myfaces.tobago:tobago-core:jar:sources:2.0.9-SNAPSHOT in
> sonarsource-downloads (
> http://nexus.internal.sonarsource.com/nexus/content/groups/ss-repo/)
>
> My searches on this have come up empty. Can you point me in the right
> direction?
>
>
> Thx,
> Ann
>
> ---
> *G. Ann CAMPBELL* | SonarSource
> Product Owner
> http://sonarsource.com
>

Reply | Threaded
Open this post in threaded view
|

Re: [Tobago] problems building

G. Ann Campbell
Hi Dennis,

Thanks for getting back to me! As luck would have it, I figured this out
probably at the exact same time you were drafting your reply.

At some point it became necessary to specify -Pall-modules, and I finally
figured that out from looking at your CI job logs.


Thx again,
Ann


---
*G. Ann CAMPBELL* | SonarSource
Product Owner
http://sonarsource.com

On Tue, Oct 13, 2015 at 1:25 PM, Dennis Kieselhorst <[hidden email]> wrote:

> Hi Ann,
>
> sorry for the late response.
>
> Which goals have you used and which Maven version are you using?
> tobago-sandbox is part of the build (a module of tobago-extension), so
> there should be no download necessary.
>
> Does the problem also occur with the branch for Tobago 3.0.x
> (https://svn.apache.org/repos/asf/myfaces/tobago/branches/tobago-3.0.x)?
>
> Regards
> Dennis
>
> Am 08.10.2015 um 19:05 schrieb G. Ann Campbell:
> > Hi,
> >
> > We're having trouble building Tobago for SonarQube analysis on
> > http://nemo.sonarqube.org/.
> >
> > Both in the CI job and locally, there's always this error:
> > [ERROR] Failed to execute goal
> > org.apache.maven.plugins:maven-dependency-plugin:2.8:unpack
> > (unpack-sources) on project tobago-sandbox: Unable to find artifact.
> Could
> > not find artifact
> > org.apache.myfaces.tobago:tobago-core:jar:sources:2.0.9-SNAPSHOT in
> > sonarsource-downloads (
> > http://nexus.internal.sonarsource.com/nexus/content/groups/ss-repo/)
> >
> > My searches on this have come up empty. Can you point me in the right
> > direction?
> >
> >
> > Thx,
> > Ann
> >
> > ---
> > *G. Ann CAMPBELL* | SonarSource
> > Product Owner
> > http://sonarsource.com
> >
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [Tobago] problems building

Dennis Kieselhorst
Thank you for letting us know.

The sources jar is now always build, see: issues.apache.org/jira/browse/TOBAGO-1507

Regards
Dennis