Upgrade to myfaces1.0.9

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Upgrade to myfaces1.0.9

Mathias Peters
Hello to everybody,

I am upgrading my webapp from myfaces1.0.5 to 1.0.9.
I realized, that the package structure changed, so I changed it to
org.apache... instead of net.sourceforge...
It took me a while to find all occurences but now I'm pretty sure I found
all.
Deployment on jboss 3.2.5[jdk 1.5] works fine.
But when I try to access a jsp whith faces elements I get a jasperException
like this:

***
org.apache.jasper.JasperException: Unable to compile class for JSP

Generated servlet error:
error: error reading
C:\Programme\jboss-3.2.5\server\default\deploy\...\struts-config_1_1.dtd;
java.util.zip.ZipException: error in opening zip file


Generated servlet error:
Note:
C:\Programme\jboss-3.2.5\server\default\work\jboss.web\localhost\...\org\apache\jsp\index_jsp.java
uses unchecked or unsafe operations.


Generated servlet error:
Note: Recompile with -Xlint:unchecked for details.
1 error
***

It occurs both when deploying .war file and a .war directory.
The .war file is ok, that means, I can unzip it with Winzip...


Does anyone know this issue/encountered it before?
How can I fix this?

thank u
matze