[jira] [Commented] (MYFACES-4122) Auto scroll doesn't work anymore for some environment

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] [Commented] (MYFACES-4122) Auto scroll doesn't work anymore for some environment

My Faces - Dev mailing list

    [ https://issues.apache.org/jira/browse/MYFACES-4122?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16047299#comment-16047299 ]

Taro App commented on MYFACES-4122:
-----------------------------------

Latest version of Chrome already faces the issue when using high DPI display.
Firefox will face the issue starting version 55: https://bugzilla.mozilla.org/show_bug.cgi?id=1151421
Not sure about other browsers.

> Auto scroll doesn't work anymore for some environment
> -----------------------------------------------------
>
>                 Key: MYFACES-4122
>                 URL: https://issues.apache.org/jira/browse/MYFACES-4122
>             Project: MyFaces Core
>          Issue Type: Bug
>    Affects Versions: 2.2.12
>            Reporter: Taro App
>
> Auto Scroll doesn't work anymore for some environment. This is because auto scroll code assumes scroll position to be integer value where some browsers begin to return floating numbers. See org.apache.myfaces.shared.renderkit.html.HtmlJavaScriptUtils.getAutoScrollFunction where it parses scroll positions assuming they are integers, and if not, it ignores those values and prints out error "Error getting y offset for autoscroll feature. Bad param value"



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)
Loading...